Bug Report: Overlapping areas when increasing Text Size (iOS)


(Marcel Ruhf) #1

Hi there,

It looks like the UI (on iOS) doesn’t scale properly when increasing the text size in Settings
To reproduce this:

  1. Go to “Settings” from your home screen
  2. Tap on “Display & Brightness” (at least on iOS 11)
  3. Tap on “Text Size”
  4. Assuming that you start the slider from the leftmost position, slide it to the right six times
  5. Open the Monzo App. The problem occurs on the Account, Payments and Help screens.

This gets worse when further increasing the font size.

I’m attaching screenshots to this thread.

![IMG_3204|281x500]


(Andre Borie) #2

That is awful indeed, I’m surprised it’s so broken given most of the UI elements (especially the TableView in the help tab) are stock and thus should behave just fine.


(Ian Lyon) #3

That doesn’t look right at all, @MRMR. I’ve just followed your reproduction steps and this is how mine looks.

What iPhone/iOS version are you using?


(Marcel Ruhf) #4

@ilyon Ah, that’s strange.
What version of iOS are you on?


(Ian Lyon) #5

iOS 11.2.5 (Developer Beta 5). If anything, I should be the one experiencing bugs since I’m on a beta :sweat_smile:

If you haven’t already, can you try a delete/reinstall and see if this fixes things?


(Marcel Ruhf) #6

@ilyon yeah, I’ll give that a go and post back on here with the outcome.


(Ian Lyon) #7

Thanks! Hopefully that sorts it :crossed_fingers:


(Marcel Ruhf) #8

@ilyon Hmm the issue still persists (as in the screenshots).
Just to be certain I’ll post the screenshot of my Text Size settings page.
Sorry for bothering you on this one, but this is crucial as I have limited eyesight.

Thanks for your help!


(Ian Lyon) #9

It’s no bother at all! Accessibility is really important to us; if this is an issue, we want to make sure it gets fixed.

Do you have any other accessibility features enabled, other than Bold Text and Button Shapes? I can’t seem to replicate this on my iPhone X, but getting an idea of what could be triggering this would be really helpful.

Feel free to send me a DM with more info if you’d prefer :slightly_smiling_face:


(Marcel Ruhf) #10

@ilyon No, besides changing font size and toggling on Bold Text, I haven’t enabled anything else.
For your info, this is on an iPhone 7 Plus.

Other than that though, it’s a great app to use :+1:, so keep up the good work!

EDIT: I’m on iOS v11.2.2.


(Ian Lyon) #11

Thanks @MRMR!

This is a weird one so I’ve raised it internally. If I get word of a confirmed fix/bug, I’ll update here to let you (and anyone else who might happen to experience it) know :+1:

Give us a shout if you have any other issues in the meantime!


(Matthew Voce) #12

Hey @ilyon

You can replicate the issue by turning on Larger Accesibilty Sizes in Settings>General>Accessibility>Larger text

Changing the text size and turning on bold text doesn’t replicate the issue but turning on Larger Accesibility Sizes does.

Hope this helps :blush:


(Ian Lyon) #13

There it is! Top marks @matthewjvoce, thank you :clap:

I’ll let the team know and hopefully this’ll be easy enough to fix!


(Marcel Ruhf) #14

@matthewjvoce Nice one! :+1:


(Matthew Voce) #15

No problem @ilyon & @MRMR

Happy bug hunting! :ant:


(Change Works) #16

Don’t let Android users know! They’ll be demanding OS parity :wink:

Now, where can I find a suitable disguise? :clown_face::clown_face:


(Marcel Ruhf) #17

It got worse in 1.9.25 when Scheduled Payments were introduced in the Payments tab.