Apple Pay fails to add

Running the TestFlight version of Monzo, along with other apps. So you can imagine sometimes I need to reset the iPhone and reinstall everything, every single time, the Monzo card fails to add

Tried deleting the TestFlight version and the released version from the App Store, still the same

Do you not get an in-app notification to verify the card?

You can’t add Apple Pay card through the app in TestFlight. Will need to it manually through the wallet.


Doesn’t matter how I try to add it, in app, entering the card details manually via the wallet, it fails

Nothing to do with running TestFlight pre-release version of the app as I have tried with the official app from the App Store

After accepting T&C, it then fails, saying contact card issuer

According to Monzo, there has been no request to add the card, nothing showing on their system

I can add cards from HSBC and First Direct no probs

I have even reset the iPhone and started from scratch with app from the store, still fails