App Exits After Clicking Link in Log In Email


(Gaby Sonmez) #1

I have a problem to activate my card whenever I tap on the email link to log into the Monzo app it chucks me out of the app and I have to start again with the same results. Any idea what is the problem?


(Sy) #2

Hi Gaby. If you give your phone make and model, and details of the operating system and version number you are running, that may help. But have you tried contacting Monzo customer operations team (help@monzo.com) as they may be of more assistance than asking fellow customers on this forum (though there are some really helpful people here too)


(Alex Sherwood) #3

Unfortunately it sounds like you’ve come across the bug if affecting quite a lot of Monzo users. If you delete the app & then reinstall it, that should resolve the problem for you. The team are aware of the issue & they’re working on a fix.

If that doesn’t work then I’d take Sy’s advice.


(Andy McGuigan) #4

+1 from me, I had this exact problem and deleting the app & reinstalling fixed it.


(Jason Alner) #5

I’m having a persistent problem with the Monzo app which is driving me to despair. After shutting down and restarting my phone completely, I was able to provide my date of birth and address etc. and proceed to the verification process. I completed the passport photo and video recording steps and have been awaiting verification.

I received a notification from the app that I was unable to read before it closed. So I opened the app have attempted to proceed to the next step, I don’t even know if I’m verified because I keep getting the same problem, over and over again. Please see below, both app and iOS are up to date.

  1. I shutdown my iPhone (iOS 9.3.5) completely.
  2. Restart my phone
  3. Open Monzo app
  4. Press ‘Already have an account? Log in
  5. Enter my e-mail address, press continue
  6. Press ‘Open e-mail’ which takes me directly to iPhone mail app
  7. Open ‘Log in to Monzo’ e-mail that’s just been sent
  8. Tap the button that says ‘Log in to Monzo which opens Safari web browser, pop-up notification states ‘Open this page in Monzo? I press ‘Open’
  9. Opens Monzo app which then proceeds to crash
  10. Repeat!

(Alex Sherwood) #6

I’m sorry to hear that you’ve run into this issue & thank you for sharing the detailed steps to reproduce it. As mentioned earlier in the thread, deleting the app & reinstalling it should fix the issue.

Monzo are (very) aware of the bug & working to fix it.


I’ve moved your post here, as it makes it easier for other users to find information about a bug when it’s all in one place.


(Jason Alner) #7

Excellent! Thank you that worked :smile:


(system) #8

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.