[Android] Bug creating Joint Account

Issue:
Trying to open a joint account, on the joint account terms page a white loading icon keeps spinning. “I accept” button doesn’t appear.
“Save” button also doesn’t work, it is completely unresponsive.

Details to reproduce:
Either after receiving a notification about someone inviting me to create a joint account or after Contact selection if I’m initiating.
On the page showing the terms the bug occurs.

OS:
Android 9 (Pie)

Device:
HTC U12+

App Version:
3.37.0

Screenshots:

Getting the same issue on a Pixel 2XL on Android 10, app version 3.44.1. Are there any alternative ways to open a joint account? Seems like it’s been impossible to do so on Android for the past two months.

Have you tried the uninstall/reboot/install routine?
This generally fixes random issues such as this.

1 Like

same thing happened for us, on two different android phones. a barely visible spinny thing for ages… mine went thru eventually, my partner gave up

I’ve tried, doesn’t help.

I find it funny that after an entire year, something stupid like this is what ended up making me open a Starling account.