Say hello to iOS Health team at Monzo 🍎 🩺

The only thing I can possibly think of is, does it cache The receipts that you put on as those could be 5 MB apiece

I’m (fairly) sure it had been identified as a memory leak previously, something the ‘iOS health team’ had been setup to look into. But the last update was from @leewatkins nearly a year ago, so I don’t know what’s happened since.

@DaleBuckley has popped in occasionally too.

Does this team still exist for this purpose?

2 Likes

I don’t add receipts for things. I’ve got connected accounts and pots. I had some custom pot images when I first started using Monzo (so they will be there, but only 3). I haven’t used custom images for anything in the last year, certainly nothing that would account for 10s of MBs in the last month and a bit.

I’m guessing not. They seems to prioritise the logout issue (which I never came across) and general stability but this one seems to have been forgotten.

I imagine the others are higher priority as they’re more directly impactful on people, whereas (as annoying as this could be!) it can be solved by deleting/reinstalling the app, at least temporarily! Whereas logout issues and other issues probably had more direct complaints through to customer services.

I went though deleting and re-installing with one of the team when this was first mentioned, but it didn’t fix the issue. The data came straight back.

1 Like

The whole deleting and reinstalling shenanigans never worked for this one. If your app documents and Santa balloons, it’s there to stay until Monzo fix it.

It’s a weird one too. It hasn’t happened to me, but my friend who is very new to Monzo and only opened an account recently purely for the savings pot had this problem from pretty much immediately installing the app and signing up. They now can’t update iOS without deleting Monzo first, which is a lot more than a minor annoyance or inconvenience.

It’s like with the crashing issue that seemed to spur this team. You couldn’t really appreciate the impact of it unless you experienced it the way I and others did, persistently and without a reliable remedy.

I’m very surprised after all this time this hasn’t been fixed or prioritised yet. It’s probably the most pressing bug with the app right now, and has been since the crashing and memory leaks were resolved a year ago.

4 Likes

@Djcnrurhf What version of IOS are you on?

iOS 17.2.1 on an iPhone 12 Pro. I’m basically always on the latest OS and always update the app whenever updates are released weekly. So this has been a problem on all iOS/app versions since I joined Monzo 18 months or so ago.

Did you try to delete the app and reinstall (you’ll have to log in again, and video verification probably)? Does it still fetch the 4.4GB back?

OK I deleted the app on Friday and re-logged int. It’s not pulled down GB of data (but that that would take a long time given my phone signal and broadband speeds here). But it’s creeping up about 15MB a day at the moment so is up to 90MB which is fine. Could just be caching data as I use it so will see where it gets to.

I did used to have a joint account and pots which are now closed, so I can’t browse all of the accounts I used to have on the device so may be that will make a difference also.

But so far so good unless the 15MB/day continues.

2 Likes

:crossed_fingers: it works out in the end

1 Like

iOS app having issues tonight, is this the right forum thread? Android app seems to be working

1 Like

It’s payday for a lot of people. Likely the pay early feature being hammered again

1 Like

Yeah, I guess so. it took me about 10 minutes after selecting to get paid earlier today.

I’d love to know how much Monzo pays out for this, likely in the million… obviously they don’t loose any money over this

I get this half the time I open app. More prevalent at night time, or when people get paid early as @Ordog says.

The feed stops updating and you can’t make payments out. Well you can, but they take an age to arrive at the other account.

There’s never anything on Monzo’s service status referencing these issues. But they’re so frequent, and they happen to a lot of people I know on iOS.

2 Likes

I suspect this team has moved on to other things now. There was going to be an update last Novemberish but I don’t think that happened?

1 Like

Well I am glad it is not just me, thankfully I am fortunate enough to have a Pixel 4a 5G that works as a backup in case I need it

1 Like

Perhaps, but they’re still around in some capacity.

I tagged them in another thread a while back, when the crashing issue that kickstarted the creation of this team resurfaced, and they were pretty quick to jump in. Given my seemingly dreadful luck with these bugs, it’s a miracle it’s not affecting me this time round. Although I’ve probably jinxed that now.

2 Likes

Argh! This is happening again today. Brother paid me back via Monzo.me, got the notification fine, but I have that error, the feed isn’t updating to reflect the payment so balance is still £0, can’t make transfers either.

It’s almost every time I actually need to use the app at this point. Ridiculous.

I don’t know if this is even the right place for it. It’s not an iOS app issue as far as I can tell, seems to be service related, though, as usual, nothing on the status page.

3 Likes