Monzo Plus link account Capital One crash

When attempting to link capital one, C1 app opens, permission screen is presented and allow is pressed it returns to monzo but there is no screen change. I press continue again and repeat but when I allow in C1 app second time it crashes C1 app and returns to monzo.
OS: Android
Device: Pixel 3XL
App Version: 3.41.1 Monzo / 8.15.6380 Capital One

Might be a C1 issue instead but thought I’d raise for visibility here.

if there’s a possibility you have revolut app installed you need to delete it and reinstall it again for some reason it’s preventing CP1

I used to have revolut installed but no longer do. For testings purposes I have now attempted three scenarios. Installing revolut, uninstalling revolut with fresh C1 install and reinstalling both. None of the three attempts fixed it.

1 Like

I had this issue as well with a back and fourth between the monzo app and the capital one app going through the motions (no revolut installed).

After quite a few tries I somehow got it to work.

Took me a fair few attempts but in the end it worked.

1 Like