Monzo crashing on launch [Raised internally - investigating]

This bug hasn’t been fixed yet unfortunately. I’ve also emailed them and I’m waiting a reply. I still can’t launch the app.

There’s a temporary fix which is to delete the app, restart your device, then install the app. That’s not working for me on the latest iPhone with the latest iOS release. According to the emergency web interface I’m currently overdrawn by £57 and being charged interest because all my money is in pots (notifications are also broke for me, and I can’t try the fix for that suggested above because, well…) :upside_down_face:

I’d normally just move to a bank that works until it’s fixed, but with no working app I can’t transfer my money out, so I’m a bit trapped right now which isn’t a nice feeling. Hopefully it’s fixed before my next credit card bill!


This is bad :scream:

If I was an iOS user and my belief and trust was in Monzo to be the bank for me - and then experienced this crap crashing issue, I’d personally be reaching for a temporary :android: device to ensure my financial plans were on track.

Not a great side-issue to have to deal with though - why have to switch platforms for reliable service?


Good shout actually! I’ve got an old nexus tucked away in my office. Don’t know why I didn’t think to try this. Probably too caught up in the frustration and stress! Thanks!


But still, this feels pretty unacceptable to me. Important it gets prioritised and fixed PDQ!



I personally have never experienced this, on iOS, thankfully.

But, as a bank “that lives on your phone” this would be a critical expectance. In that if for some reason I couldn’t get it to work, repeatedly, I would leave for this.



Although, it’s also having the opposite effect: I won’t countenance moving to iOS until Monzo is robust on that platform. So many issues on iOS over the years (even if I do still want their, much improved, search).


I think that’s a touch of an over reaction.

This is impacting a handful of people. Could easily hit android in the same way.


I’d happily trade you that for Better pots functionality!

1 Like

I’m hoping that these sort of parity issues will be looked at by @emmag and team in the app refresh.

(And I’d take that trade: I search everyday but only amend pot payments infrequently!)


For tracking purposes, the issue persists on the newly released 4.50.0 that went live on the App Store today.

Still persists on 4.51.0 which was released today.

This sounds rubbish. Obvious warning alert :rotating_light: but is there anything you haven’t tried. Reset, hard reset, delete reinstall, delete and reinstall profile (if on beta).

I only ask as I’ve never had this issue on any version of iOS with Monzo. I have had it in the past on beta versions with HSBC and others.

I also tried what you did above (hard reset the phone while the app was running) and I couldn’t replicate.

Is there anything diffident about your device to s different iPhone?

Genuinely curious as to why this persists.

1 Like

Aside from getting a new phone, I’ve tried everything. and I’m tired of trying, so I’ll admit I’ve not gone through the typical trouble shooting steps each new update (I just update and see if it’ll launch), and honestly, I shouldn’t have to.

The delete, restart phone, reinstall trick used to fix it, until it would crash again a few days later and the previous steps had to be repeated. That alone was a dreadful experience.

I appreciate the steps I’ve outlined haven’t worked to replicate the issue. They have worked for me to replicate on dev devices which consist of a brand fresh install of monzo that aside from being launched, has never been logged into or set up, to rule out any settings within Monzo causing it. But I’m not the only person it’s impacting as evidenced by folks above and in the other threads I’ve linked to. You’ll find a bunch of folks complaining about it on twitter and reddit too.

@JJWILK088 seems to be stuck in the same situation I’m in, so I’d be curious if they’ve found a way to fix it.

I don’t know if there’s anything different about my device vs other folks, I don’t have any particular sort of special setup, I tend to stick to defaults for most things. The only setting I change for Monzo is to enable Face ID for authorising transfers and confirming purchases vs my card pin. But that’s not the cause because it’s happened whilst I’ve had it disabled too. Nor would it explain why a fresh installation of the Monzo app crashes on launch too.

But who knows, it wouldn’t be the first time a bug has been triggered by something odd that seemingly has no discernible connection. Equally it could just be something in Monzo’s app which only discriminates against a particular thing so as to only manifest for some folks and never for others. I’ve had an app crash before because it plugged into my contacts. One of my friends has accents in her name, and one of those accents would cause the app to hang. Or like a bug equivalent of what Uber did to Apple to trick their app reviewers. Perhaps it doesn’t like my v6 IP (most folks are still v4) address and that causes the app to get stuck that it can no longer be launched. Your guess is as good as mine. Apps are complicated; moreso when they’re a front end for a service as complex as Monzo. Only Monzo has the looking glass required to identify the cause and fix it. All I can do is look for patterns that can hopefully point them in the right direction.

I steer clear from beta software, only resorting to installing the Monzo TestFlight build to try to overcome this bug and another. I’m currently sticking with the release builds. I’ve moved everything over to RBS for now, so it’s no stress at this point, and I care little for trying to fix it myself. I’ll keep checking every update, nag the thread, and hope Monzo will eventually issue a proper fix on their side.

Edit to add: If it helps, although it first happened to me on July 8th, it appears to have began around the time the neon cards launched, correlating when the consistent and frequent reports from users began appearing online. Several the day those cards launched, and a steady stream of them since then up until now. Prior to that date, complaints of crashing were scarce and not happening upon launch of the app.


Still no joy dude. I’ve just updated iOS and the app still the same issue crashes before it even launches. It’s my main bank and a huge hassle to switch so for now I’ve installed it on my iPad so I can manage pots and authorise online stuff, but it’s far from ideal. Monzo support just keep saying the devs are aware but clearly it’s not a priority. I considered a new phone or switching to Starling but there’s nothing wrong my phone and Starling is missing a few features that would make the way I manage my money more difficult. However paying £5 a month for plus when I can’t even use the app when I’m out is leaving a bad taste

1 Like

@AlanDoe is there anychance you can help?

1 Like

Monzo support just keep handing me around like a putrid hot potato copying and pasting from a script. Would be good to hear from someone who actually knows &/or cares what’s going on. Been with Monzo since Mondo days and I really don’t want to switch accounts over this


@Moddingfriendly you seem like a gentleman who might help point us in the right direction of who to speak to :pray:t2:

1 Like

@TheoGibson you also seem like someone who gets things done :grimacing::face_holding_back_tears:

This is super interesting if you’ve been able to reproduce this across multiple devices. @.AlanDoe when they are online should be able to contact you to try and get your Monzo account (as we don’t want your information available on the forum or in DMs with staff due to GDPR) and then we can have a closer look into if there’s anything specific going on.

Personally the app is working fine for me, but I am aware of a bug that cases a crash after a cold boot (sometimes) but normally the app recovers.

I’d possibly recommend trying out TestFlight, just in case you have a feature flag enabled that is trying to look for some app code that doesn’t exist yet.

Once we can look into this properly we can hopefully get to the bottom of this.

Just as a heads up as I see this thread has been going on for a while, please do report these things on the community but also email us at we treat these as serious issues that we need to fix for our customers.

  • Kyle

Also a tiny reminder, sending pings at midnight isn’t the best way to get a response. just as some of us (myself included) have notifications on on our personal devices. We love helping on the community but please be mindful of pings :hot_coral_heart: