Monzo crashing on launch [Raised internally - investigating]

Really daft q maybe but is this over wi-fi and mobile data? As IPV6 is set by the network, not the device (in most cases unless forced).

Have you tried and tested both over wi-fi/mobile?

Do you also have a VPN installed or set up?

Lastly, have you reset one of your iPhones to default, only downloaded the monzo app and seen how functional or not it is from a fresh install, nothing else done to it prior?

Does seem unusual your app seems to be having a lot more difficulties than some others.

Edit for other last: have you tried a completely different WiFi network and/or mobile network just to rule each one of those things out?

FWIW: EE was having issues with the chase app recently. Which could have included EE, 1p mobile, BT, PlusNet, or any other linked brand.

You can rule that one out because I’m also IPv6 (AAISP native). If I’m not on WiFi, I’m on EE or 3 (Smarty) and EE is also IPv6.

I feel your pain. Having been a problem solver for the latter part of my working life it really frustrates me not knowing why something is happening and not being able to do anything about it!

1 Like

It’s not set by the network, as such - it’s made available by the network and it’s up to the device’s OS whether it takes any notice of IPv6 Router Advertisements. Most OS default to IPv6 if available.

That aside, I’ve had no issues with the Monzo app crashing on either my WiFi, EE (which uses IPv6) or other IPv6-enabled WiFi networks.

@N26throwaway - it makes me wonder whether your data on Monzo’s servers has somehow been corrupted. I’ve seen behaviour like this when user data on RADIUS servers has become corrupted, causing authentication to fail in a way that the client software hasn’t been coded to handle correctly. That’s a specific example, but it makes me wonder whether something similar is occurring.

I’ve also seen similar behaviour (now that my early morning memory has been stimulated by caffeine) where there was disparity between server data and client cached data. That took weeks to diagnose in one particular case. Fresh installs of client software often (but not always) fixed it.

1 Like

Hi Kyle,

Appreciate your reply! I have emailed Monzo about it too (and I believe so did @JJWILK088) and I’ve been escalated, just waiting on an update.

It might be this same bug, only for some reason it’s not recovering, and on iPhone 14 pro (iOS 16.0.2 and beyond) the usual trouble shooting steps aren’t fixing it for me, whilst they still work on my dev devices.

Do your guys have any idea what the cause is and when a fix for that particular bug can be expected?

The initial crash has (to my best recollection) always occurre over wifi. It persists over 4G too, but that’s to be expected.

I have several vpn profiles installed. None are in use whilst at home except for, occasionally, the local Proxyman MITM server which runs on my device. Monzo doesn’t like when I run Proxyman, and Proxyman has never been in use when the initial crash has occurred.

This is one thing I haven’t done, but only because of the hassle and time it would involve to both configure the device this way, run through my reproductive steps to test, and then reconfigure the device back to how it was previously.

My iPhone 14 is as fresh as things have gotten from that side of things.

Yeah but it’s affecting @JJWILK088 in the same way, so at least I’m not in complete isolation with the severity of this one! Most others are able to get it working with the delete, restart, reinstall approach, and I can’t fathom why that’s not working here. My guess is it’s something iPhone 14 specific, or perhaps 16.0.2 specific that’s carried over into 16.0.3.

On dev devices yes. On my personal device no, because I’m not trying to replicate it and don’t want it to happen. Just so happens when it does, it’s always been whilst my phone is connected to my home network. Or so I assume. Sometimes iPhone doesn’t automatically connect to a wifi network after booting until after you’ve unlocked it. So it could be triggering in the background over 4G.

Same setup on the home network side of things. Mobile is Sky though, which is only 4G. Also use iCloud relay which gives v6 back, but as I understand it that’s just for safari and not apps.

Yeah! There’s nothing in life more frustrating than this for me! :laughing:

Nothing would bring me greater joy than to be the employee at Monzo in charge of squashing this bug. It’s personal now.

That’s certainly a possibility!

1 Like

Sorry yes, late night posting didn’t word it right :joy:

Have you tried removing them all to see if there’s any conflict between VPN profiles (even if not active)?

The full restore to new wouldn’t take too long, just create a backup, it’ll take about 10 mins to restore to new - just ruling out trial and error - then restore from backup (depending how much stuff you have once confirmed if a fresh new device, nothing else included, doesn’t resolve)

If then said device worked with monzo, but then started crashing after restore, potentially something in your data device level, not ours, could be the issue.

1 Like


This isn’t feasible with our dev devices, restoring as new might only take 10 minutes, but to reconfigure it for it for work will take hours. On my personal device, this would unpair my Apple Watch and I risk losing a lot of my fitness progress when pairing it back up. I don’t use iCloud backups with the current encryption policies.

Would love to be able to test it, and maybe I will once we get a dev 14 pro max in, but as of right now, it’s the one thing I’m not happy to do with my devices, especially so soon after upgrading to iOS 16 (which is always done fresh).

Fairs, but doesn’t rule out all potential issues of being your end Vs fault, or bug, laying with monzo.

Being a Dev device, isn’t that naturally going to bring it’s own bugs and faults opposed to an out the box fresh device untouched :sweat_smile:

Also, what’s wrong with Apple backups? Surely their policies for the backups are no different to the security in their devices? (Unless I’ve misunderstood your point on this one)


Possibly! But they’re the only other devices I have to test on aside my iPad.

They’re not E2E encrypted.

1 Like

It may help find a resolution though.

In terms of end to end, how else do you back up your device, direct to iTunes opposed to iCloud? (if that’s even a thing any more)


I don’t backup my personal devices at all.

With everything turned on in iCloud to keep everything in sync (which is E2E) it’s just not necessary to have a backup too.

Oh got ya.

What happens if you lose or break said device?

Get a new one, sign into my apple device, everything important syncs across to it.

Just means some apps will need signing into and setting up again.


I’ve often wondered what the point of nightly backups is, I mean, all the important data (photos, messages etc) is cloud based anyway.


@N26throwaway I sent you a DM with a link to TestFlight, could you let me know if installing the beta helps fix this? Once the beta is installed then you should be able to go back to the release train a week later and you’ll be back to normal.

If this fixes your problem I’ll feed it back to the team :hot_coral_heart:

1 Like

@Moddingfriendly Thanks for getting back. Sorry about the pings just a little desperate now
:grimacing: I’m just trying to do a backup to give that a go. It’s been happening on the last 3 versions of the app and ios so I’d be a little sceptical about the beta



Just tried this. Worth noting the current test flight build is the same as the App Store release so wasn’t expecting it to do any good.

Still not working, also worth noting it’s not triggering the crash report pop up that’s supposed to happen with test flight builds.

Here’s a gif:



Could you try going into your Phone Settings for Monzo and Resetting Current Session?

1 Like

With the beta you should also be able to go back to the version where it last worked and we will be able to know exactly what version caused you the issues and work from there :hot_coral_heart:

Toggled reset session to on, still crashes.

Let me quickly try doing the TestFlight as a fresh install of the app.

ETA: still crashes with a fresh install of the TestFlight build.


Could you try installing the oldest version of the app that you can get from TestFlight? (I’m not sure if this will help as if this problem has been ongoing since 4.37)

1 Like