Monzo crashing on launch [Raised internally - investigating]

I’d happily trade you that for Better pots functionality!

1 Like

I’m hoping that these sort of parity issues will be looked at by @emmag and team in the app refresh.

(And I’d take that trade: I search everyday but only amend pot payments infrequently!)


For tracking purposes, the issue persists on the newly released 4.50.0 that went live on the App Store today.

Still persists on 4.51.0 which was released today.

This sounds rubbish. Obvious warning alert :rotating_light: but is there anything you haven’t tried. Reset, hard reset, delete reinstall, delete and reinstall profile (if on beta).

I only ask as I’ve never had this issue on any version of iOS with Monzo. I have had it in the past on beta versions with HSBC and others.

I also tried what you did above (hard reset the phone while the app was running) and I couldn’t replicate.

Is there anything diffident about your device to s different iPhone?

Genuinely curious as to why this persists.

1 Like

Aside from getting a new phone, I’ve tried everything. and I’m tired of trying, so I’ll admit I’ve not gone through the typical trouble shooting steps each new update (I just update and see if it’ll launch), and honestly, I shouldn’t have to.

The delete, restart phone, reinstall trick used to fix it, until it would crash again a few days later and the previous steps had to be repeated. That alone was a dreadful experience.

I appreciate the steps I’ve outlined haven’t worked to replicate the issue. They have worked for me to replicate on dev devices which consist of a brand fresh install of monzo that aside from being launched, has never been logged into or set up, to rule out any settings within Monzo causing it. But I’m not the only person it’s impacting as evidenced by folks above and in the other threads I’ve linked to. You’ll find a bunch of folks complaining about it on twitter and reddit too.

@JJWILK088 seems to be stuck in the same situation I’m in, so I’d be curious if they’ve found a way to fix it.

I don’t know if there’s anything different about my device vs other folks, I don’t have any particular sort of special setup, I tend to stick to defaults for most things. The only setting I change for Monzo is to enable Face ID for authorising transfers and confirming purchases vs my card pin. But that’s not the cause because it’s happened whilst I’ve had it disabled too. Nor would it explain why a fresh installation of the Monzo app crashes on launch too.

But who knows, it wouldn’t be the first time a bug has been triggered by something odd that seemingly has no discernible connection. Equally it could just be something in Monzo’s app which only discriminates against a particular thing so as to only manifest for some folks and never for others. I’ve had an app crash before because it plugged into my contacts. One of my friends has accents in her name, and one of those accents would cause the app to hang. Or like a bug equivalent of what Uber did to Apple to trick their app reviewers. Perhaps it doesn’t like my v6 IP (most folks are still v4) address and that causes the app to get stuck that it can no longer be launched. Your guess is as good as mine. Apps are complicated; moreso when they’re a front end for a service as complex as Monzo. Only Monzo has the looking glass required to identify the cause and fix it. All I can do is look for patterns that can hopefully point them in the right direction.

I steer clear from beta software, only resorting to installing the Monzo TestFlight build to try to overcome this bug and another. I’m currently sticking with the release builds. I’ve moved everything over to RBS for now, so it’s no stress at this point, and I care little for trying to fix it myself. I’ll keep checking every update, nag the thread, and hope Monzo will eventually issue a proper fix on their side.

Edit to add: If it helps, although it first happened to me on July 8th, it appears to have began around the time the neon cards launched, correlating when the consistent and frequent reports from users began appearing online. Several the day those cards launched, and a steady stream of them since then up until now. Prior to that date, complaints of crashing were scarce and not happening upon launch of the app.


Still no joy dude. I’ve just updated iOS and the app still the same issue crashes before it even launches. It’s my main bank and a huge hassle to switch so for now I’ve installed it on my iPad so I can manage pots and authorise online stuff, but it’s far from ideal. Monzo support just keep saying the devs are aware but clearly it’s not a priority. I considered a new phone or switching to Starling but there’s nothing wrong my phone and Starling is missing a few features that would make the way I manage my money more difficult. However paying £5 a month for plus when I can’t even use the app when I’m out is leaving a bad taste

1 Like

@AlanDoe is there anychance you can help?

1 Like

Monzo support just keep handing me around like a putrid hot potato copying and pasting from a script. Would be good to hear from someone who actually knows &/or cares what’s going on. Been with Monzo since Mondo days and I really don’t want to switch accounts over this


@Moddingfriendly you seem like a gentleman who might help point us in the right direction of who to speak to :pray:t2:

1 Like

@TheoGibson you also seem like someone who gets things done :grimacing::face_holding_back_tears:

This is super interesting if you’ve been able to reproduce this across multiple devices. @.AlanDoe when they are online should be able to contact you to try and get your Monzo account (as we don’t want your information available on the forum or in DMs with staff due to GDPR) and then we can have a closer look into if there’s anything specific going on.

Personally the app is working fine for me, but I am aware of a bug that cases a crash after a cold boot (sometimes) but normally the app recovers.

I’d possibly recommend trying out TestFlight, just in case you have a feature flag enabled that is trying to look for some app code that doesn’t exist yet.

Once we can look into this properly we can hopefully get to the bottom of this.

Just as a heads up as I see this thread has been going on for a while, please do report these things on the community but also email us at we treat these as serious issues that we need to fix for our customers.

  • Kyle

Also a tiny reminder, sending pings at midnight isn’t the best way to get a response. just as some of us (myself included) have notifications on on our personal devices. We love helping on the community but please be mindful of pings :hot_coral_heart:


Really daft q maybe but is this over wi-fi and mobile data? As IPV6 is set by the network, not the device (in most cases unless forced).

Have you tried and tested both over wi-fi/mobile?

Do you also have a VPN installed or set up?

Lastly, have you reset one of your iPhones to default, only downloaded the monzo app and seen how functional or not it is from a fresh install, nothing else done to it prior?

Does seem unusual your app seems to be having a lot more difficulties than some others.

Edit for other last: have you tried a completely different WiFi network and/or mobile network just to rule each one of those things out?

FWIW: EE was having issues with the chase app recently. Which could have included EE, 1p mobile, BT, PlusNet, or any other linked brand.

You can rule that one out because I’m also IPv6 (AAISP native). If I’m not on WiFi, I’m on EE or 3 (Smarty) and EE is also IPv6.

I feel your pain. Having been a problem solver for the latter part of my working life it really frustrates me not knowing why something is happening and not being able to do anything about it!

1 Like

It’s not set by the network, as such - it’s made available by the network and it’s up to the device’s OS whether it takes any notice of IPv6 Router Advertisements. Most OS default to IPv6 if available.

That aside, I’ve had no issues with the Monzo app crashing on either my WiFi, EE (which uses IPv6) or other IPv6-enabled WiFi networks.

@N26throwaway - it makes me wonder whether your data on Monzo’s servers has somehow been corrupted. I’ve seen behaviour like this when user data on RADIUS servers has become corrupted, causing authentication to fail in a way that the client software hasn’t been coded to handle correctly. That’s a specific example, but it makes me wonder whether something similar is occurring.

I’ve also seen similar behaviour (now that my early morning memory has been stimulated by caffeine) where there was disparity between server data and client cached data. That took weeks to diagnose in one particular case. Fresh installs of client software often (but not always) fixed it.

1 Like

Hi Kyle,

Appreciate your reply! I have emailed Monzo about it too (and I believe so did @JJWILK088) and I’ve been escalated, just waiting on an update.

It might be this same bug, only for some reason it’s not recovering, and on iPhone 14 pro (iOS 16.0.2 and beyond) the usual trouble shooting steps aren’t fixing it for me, whilst they still work on my dev devices.

Do your guys have any idea what the cause is and when a fix for that particular bug can be expected?

The initial crash has (to my best recollection) always occurre over wifi. It persists over 4G too, but that’s to be expected.

I have several vpn profiles installed. None are in use whilst at home except for, occasionally, the local Proxyman MITM server which runs on my device. Monzo doesn’t like when I run Proxyman, and Proxyman has never been in use when the initial crash has occurred.

This is one thing I haven’t done, but only because of the hassle and time it would involve to both configure the device this way, run through my reproductive steps to test, and then reconfigure the device back to how it was previously.

My iPhone 14 is as fresh as things have gotten from that side of things.

Yeah but it’s affecting @JJWILK088 in the same way, so at least I’m not in complete isolation with the severity of this one! Most others are able to get it working with the delete, restart, reinstall approach, and I can’t fathom why that’s not working here. My guess is it’s something iPhone 14 specific, or perhaps 16.0.2 specific that’s carried over into 16.0.3.

On dev devices yes. On my personal device no, because I’m not trying to replicate it and don’t want it to happen. Just so happens when it does, it’s always been whilst my phone is connected to my home network. Or so I assume. Sometimes iPhone doesn’t automatically connect to a wifi network after booting until after you’ve unlocked it. So it could be triggering in the background over 4G.

Same setup on the home network side of things. Mobile is Sky though, which is only 4G. Also use iCloud relay which gives v6 back, but as I understand it that’s just for safari and not apps.

Yeah! There’s nothing in life more frustrating than this for me! :laughing:

Nothing would bring me greater joy than to be the employee at Monzo in charge of squashing this bug. It’s personal now.

That’s certainly a possibility!

1 Like

Sorry yes, late night posting didn’t word it right :joy:

Have you tried removing them all to see if there’s any conflict between VPN profiles (even if not active)?

The full restore to new wouldn’t take too long, just create a backup, it’ll take about 10 mins to restore to new - just ruling out trial and error - then restore from backup (depending how much stuff you have once confirmed if a fresh new device, nothing else included, doesn’t resolve)

If then said device worked with monzo, but then started crashing after restore, potentially something in your data device level, not ours, could be the issue.

1 Like


This isn’t feasible with our dev devices, restoring as new might only take 10 minutes, but to reconfigure it for it for work will take hours. On my personal device, this would unpair my Apple Watch and I risk losing a lot of my fitness progress when pairing it back up. I don’t use iCloud backups with the current encryption policies.

Would love to be able to test it, and maybe I will once we get a dev 14 pro max in, but as of right now, it’s the one thing I’m not happy to do with my devices, especially so soon after upgrading to iOS 16 (which is always done fresh).

Fairs, but doesn’t rule out all potential issues of being your end Vs fault, or bug, laying with monzo.

Being a Dev device, isn’t that naturally going to bring it’s own bugs and faults opposed to an out the box fresh device untouched :sweat_smile:

Also, what’s wrong with Apple backups? Surely their policies for the backups are no different to the security in their devices? (Unless I’ve misunderstood your point on this one)