Issue with 3D Secure?

Is anyone else having issues with 3D Secure authorizations? I went to place my weekly shop yesterday and kept getting the red invalid secure token error message so I chose the SMS option, got the text and never thought more about it.

But was just buying some birthday presents just now and I tried 5 times to approve it and still kept getting the red error message and then chose the SMS option and got no text, so clicked the box again … then about 20 minutes later got the approval text (both of them) which worked but a bit slow I thought …

I had a look around the forum and searched and saw a couple of people brought it up on the testing in the Labs and people thought it was to do with approving with Face ID but I didn’t see anyone confirm/deny that.

PNG

I am having the same token error all the time and have to use sms option.

Hopefully @Rika will know the answer to it on Monday! :crossed_fingers:t2:

Used 3D secure twice this week with no problemo. However I’m using an iPhone

I had an issue yesterday where I kept tapping approve but nothing happening. Reverted to SMS and all fine.

Might go back to using my Nationwide credit card and set aside the amount in pots - no authentication there.

I already raised the text issue in another thread. My texts are taking 10-15 minutes now to come through. That’s too long to wait on a page.

1 Like

Asda app on Thursday night only took seconds for the text to come through

2 Likes

Same when I did it last night - it was instant!

1 Like

Have you reinstalled the app or turned off and back on Touch ID / Face ID for authentication?

Maybe it may help.

On another note there’s a fix for 3DS authentication issues in the current test flight app which do may resolve the issue? My guess is this app update will hit the store next week.

image

1 Like

I switched off the Face ID, haven’t re-installed the app yet as still at work and signal here is bad and no wifi. Although I don’t need to buy anything now haha!

1 Like

3D Authentication wasn’t even presented to me earlier when I did my shopping online.

I’ve used 3DS on a few different sites and approval from within the app has been flawless. Just a few too many clicks to get there that’s the only problem.

1 Like

There’s a fix for this in an upcoming update. For now, turning off and then back on Touch/Face ID for Authentication from the app’s settings manually fixes it. :+1:

5 Likes

Thanks! Works like a charm! Just bought something with no issues :smiley:

1 Like