Forced software updates


(Dave Mellor) #1

I am not sure if this is a bug or a feature so any Monzo developers out there please comment.

I transferred money from NatWest to Monzo but it didn’t immediately appear in my Monzo account.

I tried to run the Monzo app but it kept failing with unknown error. Then a ‘Software Update’ required message appeared (can’t remember the source of the update message :frowning: sorry).

I applied the update and my money transfer went through!

I was impressed - if that was intended - but was it?

So a feature or a bug? Monzo developers please respond - or anyone else out there who knows.

Regards

Dave (retired developer) :sunglasses:


(Rika Raybould) #2

Hi Dave!

Not a developer but I am a technical specialist on our overnight support team! Was this the Monzo Current Account Preview app on iOS? One of the TestFlight builds of this expired within the last day. Unfortunately, we have little control over this as it’s part of Apple’s app testing system. :slightly_frowning_face:

We have also finished the preview now so the current account preview app won’t be updated beyond the current version that just extends the expiry date.

The good news is that if you open the latest version of the main Monzo app from the App Store, you should see a banner along the bottom offering to upgrade your account, merging your preview current account and prepaid beta accounts into a full current account. This will also allow you to access new features such as Pots. :tada:

(By the way, a quick log out and back in fixes any missing data from the preview that doesn’t appear in the main app after upgrading. :wink:)

If you’re on Android, the same general advice applies here too. :slightly_smiling_face:


(Dave Mellor) #3

Thanks for replying. Sorry I respond intermittently am retired developer with time on hands!
I was sorted by your advice but have just found another possible bug maybe install related. Just entered it by posting to Tony (Monzo software engineer - I think).

It is an unclean uninstall bug. Persistent data after installation. Hell to cure on Windows - been there etc.

Bye
Dave