[Android] Cannot update pot images


For the past 2 weeks I have been unable to change the image on the pot with one I upload myself, using one of monzo’s stock images works fine though. Everytime I change the image and click the submit button I get an error message telling me that it cannot be completed and this time. I have contacted support about this but no one seems to have any idea how to solve it. I have done the usual, reinstall, clear cache, restart phone etc but the problem persists. Looking through the thread I don’t see anyone else having this problem.

Hi, I’ve moved it to the bug reports section as it sounds like a software bug considering all the troubleshooting you’ve done.

Also if you can add the phone and software version that would help.


I am currently using a Samsung S9 and Android version 9.0. I recently updated to the beta monzo app in hope this may solve the problem, so am currently on version 2.54.0


When you click edit , choose from gallery , then it asks you to choose source, which option are you using ? Have you tried using the file manager.

I have tried adding the image from the gallery app, using file manager, and direct from Google drive and still have the same issue

Did it let you send a screenshot to support, or did you get the same error?

I did send a screenshot to support and they said they would escalate it but I haven’t heard anything since.

is it for every image in your gallery ? or just the one you’re trying ?

It happens on every pot, with any image. Even tried creating new pots and it still doesn’t work.