Split into categories is painful for more than two categories

I tried splitting and expense into three and it’s painful. This is how it goes.

A. 30
B. 0
C. 0

I want it to be.

A. 15
B. 10
C. 5

Doing this simple thing feels like I am solving an algebra problem or playing a puzzle game.

Changing A changes C. Changing B changes A. Changing C changes A.

Try doing what I gave as example, you simply can’t do it without lots of hit and trial. There is no intuitive way.

These categories should be drag-able and down and changing one always effect the top item, the same way it happens now. When they are drag able I can put one I want to be effected on top.

Or just add a lock button with a category so that it does not change when I am done with it

Current method is painful.

Seriously, try doing this yourself Monzo team. I just can’t adjust values without effecting another previously set category.


Hey, I totally agree this needs to change and is not at all intuitive.

It seems to be working the same way as bill splits do when you have more than one person you’re splitting with.

The way to do it without hassle is to make sure you go down the list from the second person or category.

So if you know what you want category B and C to be, you need to change B first, without doing anything to A or C, and then change C.

This will give you your desired numbers, but I agree is not clear, and there’s definitely room for improvements.


Ah I’m glad someone else has had this. I thought I was going crazy. It’s completely unintuitive.

I read somewhere that part of this behavious is so you always have a “master” category - which is always the first one on your list.

But having just tried it now I see the logic of trying to have more than one is just bizarre! Auto orders them in alphabetical order, not the order of selection. And as you say things go a bit haywire with the button pressing.

Really minor problem, but when you tap into a category to type in an amount, it puts the cursor at the end of “0.00”, would be cleaner if it just cleared blank cells.


But how did that not annoy someone in the testing team sufficiently to have it fixed? :thinking:


This really annoys me about bill splits also.

Sometimes i know how much my split should be and want to work it from there but it seems you cant do that.

Yes agree with the 0.00.

Cannot see a single reason for that not clearing - and sure it’s ‘minor’ but it’s completely ridiculous. The only thing you’d be doing when clicking into such a cell is typing a new value in, so the extra clicks to delete are always annoying and wasted time.


I just tried this and yelled at my phone. I think it needs a fix pretty urgently hah.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.