New split bill UI is bad

What’s with the new split bill UI? It starts out with the bill split evenly between the two parties, but that’s rarely the case for me. I go to edit the amount by removing what’s there, and typing in the new amount, and it doesn’t seem to recognise the period in the amount that I enter, resulting in the maximum amount being entered into the field.

2 Likes

Didn’t notice the new UI until I saw your post.
Can confirm that the same thing happens to me. I have to enter the pound amount first, then manually click after the “.” to enter the pence, as pressing “.” doesn’t do anything.

2 Likes

Not a fan of the new underlining also.
Feels very comic sanssy

3 Likes

Even split feels like the most common way to start off. Not sure why it would start any other way.

I typed and it was fine. Are you using a weird android keyboard?

Underlining feels unnecessary.

1 Like

Happens with both gBoard (Pixel phone default) and Swiftkey.
I’ve even tried the “clear cache, uninstall, reboot, reinstall” trick and still the same issue.

I do like this new UI, as long as it works. I agree that the underlining is unnecessary though.

1 Like

Happens with SwitfKey and the native Samsung keyboard, so I’m inclined to say the keyboard isn’t the issue. It’s possible it could be an Android-only issue.

Regardless, my views on what could be improved:

  • The hitbox for the amount should be larger
  • When you first tap on the box, it should place the cursor at the very end of the text, not where you tap. Successive taps should place the cursor where you tap.
  • Decimal points should be recognised as such, and cause the cursor to jump to the decimal place, not stay before, like it does now.
  • If I hold backspace, I expect the whole amount to be deleted, without the leading zero.

This screen recording should demostrate these issues perfectly:

1 Like

I get the same problem on my Pixel 7 with the default keyboard. It’s incredible frustrating considering this is just a simple amount entry field.

I can only summise that it’s some niche Android bug that not many people are experiencing. Or, not many people use the split bill feature, because from a usability standpoint, this is awful. The whole app experience has taken a real turn for the worse, especially since the introduction of the new UI. What’s more, it doesn’t feel like Monzo even want feedback.

Issue:
Splitting bill, can’t enter full stop between pounds and pence
Details to reproduce:
Split a bill down to the pence level
OS:
Android
Device:
Pixel 7 Pro
App Version:
5.69.0
Screenshots:
Doesn’t help show the issue!

The new UI is broken - when entering the split amount you can’t enter a full stop to enter the pence of the amount - it just adds the pence figures to the pound column. You have to tap on the screen to move to the pence section.
This is very frustrating considering this is a simple amount entry field.
Please fix.

2 Likes

Apologies if my last comment seems somewhat targeted/unfriendly. I love Monzo on the whole, but I really wasn’t (and still am not) a fan of the new UI, so this just feels like a continuation of that.

I do wish there was more of a bug tracker, or something with a bit more progress/feedback than just submitting a post to a forum. As it stands, I don’t know if this is something I’m doing wrong, or a bug in the app. And if it is a bug, I don’t know if Monzo are aware of, or even have plans to fix it. I’d appreciate at least some form of feedback.

Besides “Thanks, we’ll look into it” you won’t get much for such a niche issue, especially on here. Submit it via the app and someone will tell you they’ve passed it on.

If it’s something big then someone will likely reply/update but otherwise most bug reports don’t get many replies at all, mostly because they’re user error, not bugs.

1 Like

Version 5.70.0 should have a fix :+1:

5 Likes

New version is a huge improvement. Thanks for taking the time to address this. Much appreciated!

2 Likes