Monzo crashing on launch [Raised internally - investigating]

My understanding that if you follow the process above @N26throwaway you could email the logs to Monzo?

I don’t think share crash reports with developers actually works unless you’re on a beta/testflight version.

If you are, then it should be doing this for you I believe?

1 Like

FYI the team are still currently looking into it.

Deleting the app and reinstalling has resolved the issue for other users but we appreciate that isn’t a temporary fix and not a total remedy.

I’ll post any further updates when they come. :soon:


Thanks for the update!

Updating to iOS 15.6, deleting the app, rebooting, and installing fresh after a reboot has let the app launch so I can sign back in! Now I can buy my brother’s birthday present with my dodgy shops virtual card! :blush:

Using the TestFlight build again now, so if/when it does crash again it’ll send a report! Thanks @JIMMWX !


This resolved it for me too




New phone. New OS. New app version. Same issue. Getting really fed up of having to fix it. Especially now Monzo want a video when I set the app back up. :pensive:


Just to add. At this stage, with the amount of times I’ve had it happen, I believe I’ve identified the cause. It happens whenever the app is running in the background and you restart you phone for whatever reason. (It dies, you update it, or you turn it off, or you restart it as part of troubleshooting something else). I can reproduce the issue 100% of the time by force rebooting my phone whilst the app is running in the background (not swiped away).

It’s linked in some way to the other bug I’ve reported where the app opens but won’t load after your phone dies whilst the app is running in the background. Part of the troubleshooting to fix that issue involves rebooting your phone which in turn causes this one, and it means having to reinstall and reset the app twice if the other bug occurs first.

If you swipe it away and try opening from the app folder, not that link, is it the same result?

That’s the App Library, it’s not a shortcut. But yes if I turn my home screens back on and launch from there it’s the same. Done this troubleshooting before. :sweat_smile:

Only way to fix it is uninstall, restart device, reinstall, and sign back in. But I’m not gonna bother. I’m sick of troubleshooting things when things don’t work, especially when it’s a consistent endless loop, like it is with Monzo (I have this multiple times a week and it’s been going on for 3 months now). I’ll wait for Monzo to fix it and raise complaints.

I wonder if there are other factors involved because I’ve never had this problem. I’ve also tried doing what you said would reproduce it for you and it’s still OK.

Would love to know what they are so I can eliminate them if that’s the case! I’ve tested it on all my development phones running various versions of iOS, and across various Monzo app versions. iPhone models ranging from the first SE to the latest 14, and I’ve reproduced it on all of them.

I’d seen iOS 16 / iPhone 14 being a mare so wasn’t sure if was just the iOS, also not seen much in terms of feedback elsewhere (probs as don’t work frontline).

Hopefully a fix comes soon.


It’s mentioned quite a bit on Twitter. There are quite a few other threads with folks reporting what sounds like is this issue too. Here’s a few of them.

Suspect you won’t see much in the way of customers complaining to Monzo directly, given they can’t get onto the app to complain! By the time they’re back in, they probably won’t care enough either. I’ve only complained it about it on here so far. Will be sending an email off about it tonight though.


Circling back to this. How are your settings looking for the Monzo app here compared to mine?


Noticing my notifications are all on here, I think I have another bug to raise, because I haven’t gotten a single one since I got my new phone, and I’ve definitely been buying stuff.

Just curious, if you disable face ID from that list, does it work then?

Nope. The Face ID is just for payment authentication. I don’t use it for unlocking the app.

Identical, except that I don’t have the Announce Notifications option on that screen.

This happened to me last year when I used Quick Start to transfer everything from my old phone to my new one. The solution (IIRC) was to simply disable notifications in the Monzo app itself, then re-enable them.


Yeah I understand that part, I was curious if it was having issues processing any access issues on boot up, not just for payments, causing it to fail.

Some tech hero somewhere will fix it :sweat_smile:

1 Like

Did they? I still can’t open my app :confused: Monzo extremely slow on email pritty disappointing :hot_face:

1 Like

This bug hasn’t been fixed yet unfortunately. I’ve also emailed them and I’m waiting a reply. I still can’t launch the app.

There’s a temporary fix which is to delete the app, restart your device, then install the app. That’s not working for me on the latest iPhone with the latest iOS release. According to the emergency web interface I’m currently overdrawn by £57 and being charged interest because all my money is in pots (notifications are also broke for me, and I can’t try the fix for that suggested above because, well…) :upside_down_face:

I’d normally just move to a bank that works until it’s fixed, but with no working app I can’t transfer my money out, so I’m a bit trapped right now which isn’t a nice feeling. Hopefully it’s fixed before my next credit card bill!


This is bad :scream:

If I was an iOS user and my belief and trust was in Monzo to be the bank for me - and then experienced this crap crashing issue, I’d personally be reaching for a temporary :android: device to ensure my financial plans were on track.

Not a great side-issue to have to deal with though - why have to switch platforms for reliable service?