List transactions not working in Developer playground

Hi everyone,

I’m trying to list my transactions in the developer playground but I keep getting the error:

“code”: “forbidden.verification_required”,
“message”: “Verification required”,

All other requests from the playground work so I know I’m already authorised but this one consistently fails. Any advice on this?


This is the example of a transaction object according to the Monzo docs

    "type": "transaction.created",
    "data": {
        "account_id": "acc_00008gju41AHyfLUzBUk8A",
        "amount": -350,
        "created": "2015-09-04T14:28:40Z",
        "currency": "GBP",
        "description": "Ozone Coffee Roasters",
        "id": "tx_00008zjky19HyFLAzlUk7t",
        "category": "eating_out",
        "is_load": false,
        "settled": "2015-09-05T14:28:40Z",
        "merchant": {
            "address": {
                "address": "98 Southgate Road",
                "city": "London",
                "country": "GB",
                "latitude": 51.54151,
                "longitude": -0.08482400000002599,
                "postcode": "N1 3JD",
                "region": "Greater London"
            "created": "2015-08-22T12:20:18Z",
            "group_id": "grp_00008zIcpbBOaAr7TTP3sv",
            "id": "merch_00008zIcpbAKe8shBxXUtl",
            "logo": "",
            "emoji": "🍞",
            "name": "The De Beauvoir Deli Co.",
            "category": "eating_out"

Can anyone tell me which of the fields would be shown in the feed? Would it be the toplevel description or ?

Just checking: have you approved access to your data from within the Monzo app? You should have a notification in your feed asking you to do this that is generated when you do the oauth stuff.

Yeah I already had. Other requests from the playground worked, only that one failed.
I came back a couple days later and it started working so i’m guessing there was an internal issue

To check, is it this one?

Nah this resolved itself. It just suddenly started working with no changes. it’s the other thread with the error from the withdraw API

it’s this one

Ah sorry, I will change it.

Given the bank holiday there may not be a response until next week but as soon as I get an update I’ll drop by :crossed_fingers:t3:

1 Like

Guess no one from Monzo was able to help out :-(. Kinda sad, really wanted to do something with the Monzo API but it’s feeling like the support is just not there

1 Like

To be fair there was never supposed to be support for the API, it’s a nice to have for techy customers.

Also it’s working for other people, maybe it’s a cloudflare issue, try another environment and or programming language.

List transactions isnt the main issue. It started working in the playground later so I imagine that was transient.

is the actual problem i’m having. tried it locally as well (without going through cloudflare) and had the same issues