[Android] Issue with turning on labs feature

Need to tap multiple times to turn on Labs feature. To reproduce go into Monzo Labs and try to turn on any of the Labs functions. You will see the switch turn on and then off again. After the 3rd time it will stay on.

OS: Android 9 OxygenOS 9.5.11
Device: OnePlus 7 Pro
App Version: 2.64.0

I’ve tried to reproduce but I’m not experiencing this issue - the on/off selections work as they should with one tap to change state.
(Pixel 2XL, stock Android 10, Monzo beta 2.64.0)

It seems like the same happens when trying to turn it off. I have a video here: https://photos.app.goo.gl/VM4DSrkqXPmRWBz78

1 Like

OnePlus 5T here. Not experiencing this issue.

Thanks for the video - very strange! I’ve just tried again on my phone and it still works as it should.
Maybe time for a tried-and-tested phone restart?

Well who’da thought…

Just tried for a 3rd time and reproduced the issue exactly.
It is a bit random. Sometimes it works on tap#1, sometimes it takes 2 taps and sometimes 3 taps.
It doesn’t seem to take more than 3 though.

goes offline while restarting phone and eating own words

EDIT: it still does it after a restart. In fact, it took 5 taps to enable a lab setting after disabling it.

Very strange.

I just tried restarting my phone and then reinstalling app as well. After the reinstalling on the app it worked the first time by just tapping once. Nevertheless, the issue is back now:

  1. Uninstall app
  2. Restart phone
  3. Install Monzo
  4. Try to turn off/on labs feature (it works first try)
  5. Add custom app icon to home screen and reopen Monzo
  6. Go to lans and it is back to the previous behaviour of having to tap the icon 3 times.

I see the same behaviour. After Force stopping the app then running it, a lab selector state change works OK once, then it becomes random to change the state with x number of taps. Timing :bug:?

Reproduced here turning off Labs feature on a OnePlus 6T (app version 2.63.0, Oxygen OS 9.0.16) Pressed 4+ times and couldn’t turn off, going back to settings and then returning to the Labs screen allowed turning off first time. How odd.

1 Like

I’m now having this issue :rofl:

1 Like

Pixel 3a here I had that issue

1 Like

Yes it happened to me today when enabling the new security lab feature.

1 Like

Happens to me to on OnePlus 7 Pro. If you go back to settings and then reopen labs after first tap the setting has changed so something is happening :man_shrugging: