Odd Google Pay autofill issue

Had Google Pay (Chrome browser version) refuse to autofill card details as it has previously done successfully for years.

Normal flow:

  • Select “card number” field in browser
  • Google Pay suggests list of saved card details
  • Select card
  • Enter CVV2
  • Card number, name, expiry date, CVV2 field auto-populated
  • Continue checkout as normal
  • A few minutes later an “Active card check” (0 value temporary hold) transaction pops up in Monzo, separate from the actual financial transaction.

Error flow:

  • Select “card number” field in browser
  • Google Pay suggests list of saved card details
  • Select card
  • Enter CVV2
  • “Card declined” error
  • A few minutes later a “Declined” transaction appears in Monzo, also a 0 value temporary hold

Card details have not changed, and manually typing out the card details in the web page worked just as expected (successful transaction). The Google Pay app does not show anything unusual, and Google Pay via NFC worked fine earlier this morning (have not had the change to check since encountering this error).

I am having EXACTLY same issue in past 2/3 days! I thought it was because the card expired (its supposed to expire this month) so I tried adding new card and same issue as you. I tried everything, contacted Monzo and they said its a known Mastercard->Google issue with transactions.

My issue is I use exclusively GPay for everything (shopping, coffee, online stuff) exclusively since covid started and now I have to carry my card around again…

They told me to try again tomorrow but still nothing. I will give it 2 more days till I contact them again…

Also, if you remove the card from GPay and readd it, it will be stuck at verification stage (because CVV cant be verified since the card check is always Declined). Hope my touchless still works at least…

Is this just your Monzo card or all cards?

I’ve just had the same issue, except the first time it told me the CVV2 was incorrect, then the second time it did as described in your error flow. Got a Declined transaction through several minutes later for both.

Interestingly, just before I’d used it to enter the details for a different card (a Monzo virtual card) and it worked fine, got the Google Active card check through in the Monzo app. This error only happened with my physical Monzo Plus card.

Additionally, the reason I was doing it for both in quick succession is that Morrisons Groceries are not accepting any of the Monzo cards I’ve tried (mine, husband’s and my virtual) right now, even though I’m getting Morisson’s active card checks through into Monzo - it’s just the charge itself that’s being declined.

Have contacted Monzo support, will report back with any update when I receive one (waiting for Payments team, could be up to 8 hours :sweat:).

I thought this was me and contacted support yesterday. They say they are aware of the issue… It’s still not on the status page though

I’ll add that NFC Google Pay payments (tapping a phone to a reader) still work fine.

1 Like