Problem making Deposit with API

When I try making the PUT request to deposit a small amount from my account to a pot I get the following error:

  "code": "bad_request.bad_param.amount",
  "message": "must be greater than 0"

I noticed is a similar post on this forum here but I have still been unable to resolve my issue.

I get the error in my .NET app and also using Insommnia rest client

The raw request looks like this in Insommnia:

* Preparing request to***/deposit
* Using libcurl/7.57.0-DEV OpenSSL/1.0.2o zlib/1.2.11 libssh2/1.7.0_DEV
* Current time is 2019-09-14T05:50:05.967Z
* Disable timeout
* Enable automatic URL encoding
* Disable SSL validation
* Enable cookie sending with jar of 10 cookies
* Found bundle for host 0x2774cce8ca0 [can pipeline]
* Re-using existing connection! (#4) with host
* Connected to (2606:4700:20::6819:d463) port 443 (#4)

> PUT /pots/pot_***/deposit HTTP/1.1
> Host:
> User-Agent: insomnia/6.6.2
> Cookie: __cfduid=***
> Content-Type: multipart/form-data; boundary=X-INSOMNIA-BOUNDARY
> Authorization: Bearer ey***
> Accept: */*
> Content-Length: 290

| Content-Disposition: form-data; name="source_account_id"
| acc_***
| Content-Disposition: form-data; name="amount"
| 11
| Content-Disposition: form-data; name="dedupe_id"
| 1

Can anyone see what the issue is?

It looks like you are sending the parameters in form-data format. Could you make sure your request body have Content-Type:application/x-www-form-urlencoded instead?


That’s great, thanks.

Do you think the documentation could be updated to include this info?