App crashing on Trends


App freezes then crashes on Trends:Spending on iOS

Running version 5:39 and have checked but no update available

All good over here.

iPhone 14, latest beta and TestFlight.

Fine here on 13mini/ios16.6.1/5.40.0 app version.
Also fine on. Galaxy s22u/android 13/5.40.0 app.

I am on IPhone 13 Pro Max with IOS 16.6.1. Using the latest version of MONZO. The app simply crashes in multiple places:

  • When trying to add a receipt
  • Checking a card details

I’ve reboot the phone and still the same. I can barely use the app. I will switch off from MONZO if this persists for more than a week (it is a conpany account!!!)

Mine is constantly crashing out. Not there to force quit. Having to open, quickly bring up app switcher and force close while it’s opening

Sorry to hear that you’re struggling with app at the moment :broken_heart:

I’ve passed this information on to our team and they’re taking a look into this just now.

As soon as I know more, I’ll update here or ask them to post :pray:

Hi Kdigger & welcome :wave:

Please try the following:

  • Uninstall the Monzo app (no need to logout)
  • Restart your device (important)
  • Download, install & login to the Monzo app
  • Check operation of the features which were failing

The above generally fixes lots of random issues.

As a person profiecient in more than 5 programming languages, this advice is compared to, if I had a problem with a car, to turn off the car, leave it, close all doors, open the doors and try to turn it on again.

And would you believe it, sometimes the problem is fixed.

1 Like

As a person proficient with both spell-checking and providing 5++ fixes to similar issues by asking them to perform the outlined steps, I recommend trying it. Did you?

I see you’re on iOS - you’ve not restored from a backup after changing devices? That has been known to create issues.

I’d also recommend you remove the Gmail address in your profile - thankfully that e-address isn’t used for your Monzo login, but it does create exposure.

(I’m helping you, or trying to, here)


Sadly you’re not proficient with your manners.

1 Like

Anyone has anything remotely useful to say, or I just get the usual idiocracy?

It’s offered help. The reported idiocracy comes from reactions to your response.

You haven’t let me know if you’ve tried what I recommended in post#7


Looks like you’re being offered solutions and then ignoring them tbh.

Have you tried the above or just decided to ignore the help you asked for?

1 Like

I got out of the car, turned it off. Got in and try to turn it on. It still same problem. Not ignoring, but it just a waste of time. Now what? Change my phone to a new one?

Did you follow the steps in post#7?

Not interested in the car analogy, only in getting you sorted.

Probably best to just do this. Bye.

1 Like

Yep. I know. You don’t know how to solve it as well.

Was just having a look in my iPhone settings, went to the monzo app and seen “reset session” at the bottom.

Turned it on, fully closed monzo app, went back into the app and asked me to log in again.

Might clear out any issues in the background, worth a shot for minimal effort (only had to log in again via email).

Thanks for changing the email address. You can’t be too careful.

Please try the steps I posted back in Post#7 and let me know the outcome. Without trying that first, there’s no way to move forward from a clean slate.