Account check doesn't work for company name with ampersand

I was paying a bill for a company that included an ampersand, and noticed that I had to replace it with the word “And” for the name check to work properly.

Details to reproduce:
Using the details of a bank account for a company with an ampersand, try to submit a payment. You’ll get the screen “We couldn’t check this account”. I tried getting the details deliberately wrong, and then I could see the reported account name definitely included an ampersand (showed on the mismatched details screen).

When I used the word “and” instead, the check details step worked and the payment went through.

In case it’s a problem at the receiving bank’s end, it was a Santander account (09-01-28).

I have a video of the whole thing, which I can share privately, but don’t want this local company’s bnk details on a public forum.

I’m a dev, and I know how irritating it is when people guess like this, but could this issue be because you’re not encoding the & properly when you make the request through to check details? Or I guess it could be downstream at Santander’s end, having worked as a contractor for them for a while I know some of their code is quite ropy…

Pixel 4a
App Version:


Works fine for me when I pay my rent, so could be their actual trade name at their bank is “and” not “&”.


It could also be that the company limited name at the bank is completely different than their trading name.


Ah yes, I considered that, but this is contradicted by the fact that when I type the name in completely wrongly, it tells me what it should be. The correction uses an ampersand.

If you see this working for your rent, my theory would be that this is because the problem is at Santander’s end. There must be some interaction with the receiving bank, because that will be the source of truth for what the account name is, Monzo won’t be storing that information.

I would have thought this was a Santander issue and maybe something related to not encoding the ampersand.

Andrew’s and Arnold mention this as problem of their page at Paying by bank transfer They use Monzo as their bank and I was successfully able to use the ampersand when I sent them a payment. By the looks of it some banks can’t cope with it.

Quote from that page:

“Our company name is 𝙰𝙽𝙳𝚁𝙴𝚆𝚂 & 𝙰𝚁𝙽𝙾𝙻𝙳 𝙻𝚃𝙳 but some banks seem unable to handle the & (ampersand) in our name, so do try 𝙰𝙽𝙳𝚁𝙴𝚆𝚂 𝙰𝙽𝙳 𝙰𝚁𝙽𝙾𝙻𝙳 𝙻𝚃𝙳 if that is the case. You may find you are prompted with the name 𝙰𝙽𝙳𝚁𝙴𝚆𝚂 𝙰𝚁𝙽𝙾𝙻𝙳 𝙻𝙸𝙼𝙸𝚃𝙴𝙳 if your bank cannot show the & in the name.”

1 Like