Use my home IP address whilst in another location

Thanks. It’s DSL (Plusnet). I don’t think it’s a coverage problem as when the connection drops, you can be right next to the router and it won’t work.

It sometimes says ‘connected with no internet’ on my phone. Would that just mean the line is dodgy, so a new router unlikely to help?

Maybe worth changing to Virgin

Yes I have a 4K stick and used to use the method you describe without issue (openvpn for android).

1 Like

That would seem to suggest an issue with the line yes, as it seems like the router is losing connection to plusnet, and not something Nest WiFi would fix.

It may be worth contacting plusnet to see if there is a fault.

Virgin media are a decent option to switch to, but they’re not without issues either.

If you’re looking for some redundancy in the event your line disconnects like that, it may be worth looking into something like BT Halo.. It’s regular DSL just like plusnet, but comes equipped with an LTE fallback if your line goes down.

I’m biased with this recommendation, but I wouldn’t be recommending them if I didn’t stand behind the recommendation. But the ISP I use may be a good option for you. They don’t have an unlimited service, but the limit is fine for most people, they also aren’t the cheapest. Support is outstanding and they have a guarantee to fix your line if it’s faulty and you switch to them with the fault. If they can’t fix it within a month they’ll refund you and let you switch away. They’re called AAISP.


Nice one. Will look into all of that.

Cheers :+1:

1 Like

I’ll have to go get a 4K stick soon then. If I struggle I may have to pick your brains!

Thank you though

If you can, it’s worth taking a look at the phone line on the street. When I moved a couple of years ago, Internet dropped every time it rained. Turned out that BT had somehow missed the line from the pylon to my house when they were upgrading way back when and the line was in terrible shape just over the last few metres


I would suggest doing the VPN client on a dedicated device like a router or a Linux computer (with a standard router or wireless access point connected to its Ethernet port) and devices behind it are not even aware that the connection they’re getting is actually a VPN.

1 Like

Could you recommend one that would work well with open vpn? I’ve had a brief look but it’s hard to find reviews of setting the vpn on the router up. Also is it a thing where it can broadcast one ssid without the vpn and another ssid with a vpn enabled? I feel like it should be a thing :joy:

I wanted it on device as well for a fire stick in case we go away we can just take the fire stick with us and it would still work. Not having to rely on the router then.

Certainly for all the other scenarios, a vpn router would be perfect

That’s all well and good but if he only wants to send certain traffic over the VPN, in this case streaming video, it’ll be very annoying when all devices now route all traffic via the the UK.

When it comes to a router I always recommend OpenWrt which is very flexible and can connect to pretty much anything. You can buy an OpenWrt-compatible router out there and install it manually or buy one with it pre-installed. I haven’t used it myself but it seems like this company sells travel routers with it preinstalled and explicitly advertises compatibility with many VPN providers.

1 Like

4K stick

OpenVPN for android app and then per app VPN you can configure so UK TV apps use VPN nothing else does and your be set.

Reviving it again!

So all was good until last week where my friend had unknowingly unplugged the raspberry pi, he turned it back on and all was good…

Then it stopped working again and after a little fault finding, the dynamic update client has stopped updating the IP address. (After manually changing the IP address the vpn now works again)

Any idea how to reconfigure the DUC? It’s a no-ip DUC.

This is what he sent me when he said he thought he fixed it…

1 Like

Try killing the process and restarting it and see if that sorts it

Or reboot the pi,

Haha the tried and true method of turning it off and on.

I’m not familiar with PI’s so someone may have a better idea.

1 Like

I’ve never set-up a pi to do this personally, only to run as a Plex server which is tricked into thinking GDrive is a locally connected USB - hence streaming media from my GDrive to anywhere.

This guide seems to have the no-ip DUC topic covered though;

1 Like

You’d be surprised how many config errors can be cleared by a simple reboot.

Fancy hack, may have to look into doing this also.

I’ve never needed to use a service like this personally, because I have my own personal block of IPs. Finding an ISP that can offer you your own static IP should avoid the need for a service like this altogether. It doesn’t solve this issue, but it can prevent it happening again.

Try the reboot as suggested by @kolok, and enter the command sudo /usr/local/bin/noip2. Given that the command prompt states no processes are running, I’m wondering if you need to just simply start the client again with that command. Have a read through of the link provided by @davidwalton though. Has some very useful config tips for an optimal setup, along with away of automating the DUC start on a reboot.