Standing Order / Transfer Amount Limited By Current Balance

Quite frustrating to not be able to setup (or amend) standing orders that are due to come out on payday because I don’t have the money to pay them now.

Case in point - I want to adjust the amount I transfer into my mortgage account, but I’ll need to wait until after I’ve been paid because I don’t have the money required to cover the transfer right now.

Two suggestions:

  1. Give the user a warning.
    Example: “You do not have the funds required to make this transfer at the present time. Are you sure you want to proceed?”

  2. Apply a bit of machine learning to analyse past regular income and committed spending (i.e. scheduled payments and direct debits), then work out how much money is typically in the account on the date the transfer is being requested.

  • I have £50 in my account today (12 Nov).
  • On 01 Dec I want to make a transfer of £100.
  • For past 4 months I have been receiving a salary of £1000 on 1st of the month - it is therefore reasonable to assume I can expect the same on 01 Dec.
  • For past 4 months I have also had a DD for my £50 phone bill come out, a standing order come out for £200, and £250 going into a pot.
  • It is reasonable to assume therefore that I should have £500 of my £1000 salary remaining which would sufficiently cover the requested £100 scheduled payment I was trying to make.

I am able to set up a standing order for an amount greater than my current balance.

Are you on iOS or Android?

Works here on Android

I’m on IOS. Work reporting as a separate UX bug?

Yeah I’m also on iOS. I’ve also just tried amending a standing order to a value greater than my current balance - this also worked as expected.

Sounds like something screwy with your app and should be reported as a bug (which you can do here)

I’ve done this in the past (with iOS) and it appears I can do the same today without issue (setting up a £1000 payment with a £200 balance) so I’m not sure what’s going on for you.

Have you updated your app? This was an issue for me around a month or so ago. It was possible on iOS but not android, but it’s now fixed