Monzo Labs: Easy Bank Transfer

Add money

Pull the main feed down and it’s the button on the right

1 Like

it’s on the “Add Money” Button under your card on the account screen

1 Like

Thanks both. I think that’s the wrong place.

(Fixing the Payments Screen refers).


I actually think it’s the right place.

Payments are what I do when I transfer money to someone else, not get money for myself. I know the “request” feature is in there but that’s always felt wrong to me.


I’d agree that it’s in the “right” place - except when I looked for the feature manually I instinctively didn’t look in the right place - I looked where all the features are. I’d argue that that’s because the entire “add money” section is in the wrong place.



Tried it with Santander, managed to approve the transaction in the Santander app and was returned to Monzo, but it asked me to approve transaction again and took me back to Santander. It just kept repeating this.

Tried it with Halifax, and it worked without any issues.



Tried it today with my Nationwide Flexaccount. Worked a treat. Good to see that there were a number of security prompts from Nationwide and Monzo for peace of mind. I will be using this from now on

1 Like

Slight typo. “We’ve currently having trouble” should be “We’re currently having trouble” or something like “We’ve been having trouble”.


I’m getting same thing with Santander, all the way through like it’s complete, and then takes me back to where I’m entering the amt again.

Does ask for biometrics a couple of points before this. Will turn those off and retry…

Edit: turned off biometrics and retried and it worked.

Don’t have any biometrics on. Have been using the traditional sign in methods. Will give it a try once again and see.

Santander worked fine for me, with biometrics

Got mine to work now.
No idea what was different.

My payments are also working now. Looks like something has been fixed.

Not sure why biometrics have an effect like others have suggested, but I can explain what’s happening here. When the Santander app redirects you back to Monzo, for reasons we don’t fully understand (and can’t replicate) sometimes you end up in a browser instead of the Monzo app. You’ll know this happened because you will see a button that says “Continue in the Monzo app” instead of just getting the confirmation screen in the Monzo app directly.

This “Continue in the Monzo app” button was inadvertently broken for the last few days. It should now work for iOS and for Android you will get a warning that there is a known bug that will be fixed with next week’s release.

Sorry for the confusion!


Good to see and nice to see a new feature. Works with my lloyds account.

1 Like


First time I tried it took me to a web view of lloyds asking for my log in details Whcih I couldn’t remember. Slightly underwhelmed At this Point.

Realsied I hadn’t used my lloyds bank app in a while. So ios had offloaded it when I redownlaoded the LloydA app by searching and clicking for it. The experience was smooth (with a. Few spinners) and just used Face ID to authorise it in lloyds.

Great if you can improve the feature better by catching the edge case of when ios off loads apps, and giving message to reinstall app etc

1 Like

It would be great to understand what is happening in the back end when we do these. Feels like magic, and I want to see how it’s done.


Might be a blog post in the future to reveal the magic.


Totally agree, I hope this feature is the first step to more open banking integrations in the Monzo app (including the connected credit cards feature being developed to show transactions too).

Maybe then Monzo can fulfil its original mission of a “control panel for your money”!


I think that is the thing I would use most, especially being able to scroll through all my accounts in Monzo

1 Like