Monzo crashing on launch [Raised internally - investigating]

I feel for anyone who doesn’t use the community who’s in the same boat. Email, social and in app teams all just parrot each other and move onto the next person. :face_with_diagonal_mouth::arrows_counterclockwise:

It’s not parroting, it’s good practice. 99.999999999% of these faults are solved by these steps. In this instance, it’s not fixing it and Kyle and N26 are working between them now to fix. Not every person will need this because hopefully Kyle and team get to a fix because of the help from N26 and then if this fix is then pushed to production, we’ll all have it and it will solve it for you and the others impacted.


When I say parroting I’m referring to the responses from Monzo support, not on here. It’s literally “sorry, try this, let me escalate, “hi I’m taking over… try this, let me escalate, the devs are aware, hi I’m taking over” without anyone reading the previous thread or taking ownership. No one suggested test flight, reaching out on here, backing up - just an endless cycle of passing the buck. Usually support are top notch


It’s quite a niche issue on whats happening, as Revels mentioned, most of the steps given by frontline are generally able to fix most things.

But as worked out above, since 4.40 or whatever, something has changed causing very few devices to continually crash.

I’m not at work today but I don’t recall seeing any major announcement advising of the impact so it’s hard to judge.

People will contact by other means if they had such issues, whether come here, or utilise the socials.

1 Like

The actual bug causing the crash predates this. Version 4.37 was when I first experienced it but I believe it predates that build slightly too.

It’s just something has changed at some point between that build and the latest one that has made it worse on my iPhone 14 pro.

Like a dummy I didn’t note exactly which build number completely broke the app, but given the app updates since which I have logged, it was likely either 4.49 or 4.48. I presume selecting any build prior to those would have worked just as well. Will stick with 4.40 for now though, because I know it works, even though it means no dark mode for the time being.

I’ve had the “force restart phone & app doesn’t load” bug for ages. I’ve always solved it by deleting, restarting, and reinstalling the app. An absolute pain, and not something we should accept - but I do it so infrequently I’ve just marked it down as another Monzo nuance.

1 Like

Could it be related to a change such as:

From:    <string name="chat_entry_point_experiment_q2_2022_ios">enabled</string>
To:      <string name="signupsquad_idv_turn_document_over_help">enabled</string>

This change was introduced at v4.40.0 and the change from the ‘ios’ reference caught my eye.

Q2 2022 was also up to June 2022 which is when pre-4.38 versions were released.

A very long-shot, but just in case!


Hey everyone!

We’ve not forgotten about this issue - the iOS team are looking into it still so we can get to the root cause.

As part of that potential fix, we may reach out to users to help diagnose what’s happening during these failed launches.

Watch this space :eyes:


This problem started after today’s update
iOS 16.0.3 iPhone 14 pro
App version 4.52.1

To resolve I had to delete and reinstall the app

1 Like

Okay so I’ve managed to solve the problem by creating an iCloud backup, starting from a fresh iPhone installing the monzo app and logining in, then resetting again and restoring my phone from the backup then reinstalling monzo. It must be something to do with my data being corrupted and still stored on my phone even after deleting the app. I reported all my crashes in TestFlight if you guys want to investigate further. Finally! :face_holding_back_tears:

1 Like

That’s a very over complicated process to get it working! Glad it is finally working for you again though!

Let’s just hope Monzo have a patch for this bug soon so it doesn’t break again! :crossed_fingers:


Arghhh I’ve just encountered this dreaded bug :sob::sob:.

My iPhone randomly restarted (not initiated by me) and now Monzo is crashing on launch :slightly_frowning_face:.

I’ll try deleting and reinstalling just now :pray:

1 Like

Got it working again :sweat_smile:

Don’t know if all these steps were necessary, but I reset the Monzo session in settings, deleted the app, switched phone off and back on, reinstalled app from the App Store, and it’s working again :slightly_smiling_face::pray:

1 Like

Annoyingly, deleting and reinstalling has made me lose the dark mode options in settings :slightly_frowning_face: so not quite back to normal.

Edit: now it’s appeared again lol…

1 Like

Dark mode settings has its own issue. Not sure if it’s a bug or intended given it was the same to activate it during beta (but it does feel like a bug). To get dark mode settings you need to quit the app and relaunch it after you first set it up.

1 Like

Ah! 4.40 crashed! Had to reinstall but the build isn’t available, gone through a few TestFlight builds, the latest one worked, but it broke Trends! It doesn’t update update, and trying to save different accounts/pots selections just stays loading forever. Trying to troubleshoot that broke the build, and now it won’t work.

When I try others I’m getting this weird flash of a broken version of the new logo before it shows the old one, then it crashes.

Have Monzo made any progress with this bug yet?

1 Like

I have the same issue in Trends where trying to save different accounts/pots selections just spins round and round forever when you click done.

1 Like

Thanks for confirming that’s not just me!

Made a thread for it here:

1 Like


Since iOS16 has graced us with it presence I’ve had to on average of 3-4 times a week delete the app, reboot the phone and download it again. The app constantly crashes out and l have never had this issue with any of the other versions of iOS.

It’s becoming quite a pain. Tell tail signs that I’m going to have to do it.

  1. The notification badge doesn’t disappear
  2. When I have to approve a payment
  3. If someone sends a payment request.

I have put up with it since it came out and I’ve gotten so fed up I did a clean install of my phone yesterday again. Last time prior to that was 5 weeks ago.

Is this something that other people are experiencing. Someone at my work showed me logs of where the iOS can see this happening.

Don’t know what more I can do. :woman_shrugging:t2:

There’s a few threads about it, Monzo are aware and investigating.