Monzo crashing on launch [Raised internally - investigating]

Only that it’s now Monzo version 4.41.0. Everything else is still the same. I’m no longer running the test flight build, which I downloaded to fix it last time.


I can’t open Monzo either right now. Force closing itself before launching

1 Like

I notice you’re launching it via a shortcut so you can use a custom icon. Does it do the same if you open it directly?

That’s the premium icon not a shortcut. You can change your app icon in the app settings

Ah, I didn’t realise Premiums got the white icon.

Yeah, mine’s the icon you get for having monzo plus

I’ve tried pretty much everything aside from completely resetting my phone and can’t launch Monzo at all. Just crashes every time I launch it. TestFlight build too.

Was updated to 4.41.0 yesterday and that’s the same version that’s on TestFlight, so I wonder if it’s that update that’s just completely bricked the app for me.

1 Like

I find this strange as I’m on iOS 15.6 on iPhone 13 pro max running monzo 4.41.0 and have no problems launching and running the app

Do you all have developer mode enabled on your iPhones if using iOS 16?

I’m not using beta software. iOS 15.5 on my personal device.

Like the other issue where the app will launch but won’t load, I don’t think it’s specific to any kind of iOS version. @JoeT’s on the iOS 16 beta, and this sort of thing has been reported on 15.4 as well.

For me these bugs together predate iOS 15 entirely, so I’m not sure iOS version, or any settings therein matter much if at all.

I’m not hopeful but I’ll install this update to see if it helps at all.

1 Like

I’ve raises this with our engineering team and as soon as I have an update I’ll post in here :pray:


Thanks Alan!

1 Like

I’m sure you know how to do this, but this article might help you submit a crash report to Monzo

(I realise it’s a different app, but the steps are the same)

1 Like

What’s the actual process for sending these to Monzo though? There’s no actual proper channel for reporting bugs, and Monzo always send you here for those.

Can’t exactly share the full file fully on here for privacy reasons. There don’t appear to be any logs generated following the start of the launch crashing yesterday. They stop a few hours prior, which I presume was from my last successful app launch.

If there is a crash we should be notified automatically (if you have share crash reports with developers enabled) otherwise we will just get a ping that there was a crash detected (at least that is my understanding of how our iOS pipeline works)

As I’m a backend engineer :pinching_hand: :salt:


My understanding that if you follow the process above @N26throwaway you could email the logs to Monzo?

I don’t think share crash reports with developers actually works unless you’re on a beta/testflight version.

If you are, then it should be doing this for you I believe?

1 Like

FYI the team are still currently looking into it.

Deleting the app and reinstalling has resolved the issue for other users but we appreciate that isn’t a temporary fix and not a total remedy.

I’ll post any further updates when they come. :soon:


Thanks for the update!

Updating to iOS 15.6, deleting the app, rebooting, and installing fresh after a reboot has let the app launch so I can sign back in! Now I can buy my brother’s birthday present with my dodgy shops virtual card! :blush:

Using the TestFlight build again now, so if/when it does crash again it’ll send a report! Thanks @JIMMWX !


This resolved it for me too




New phone. New OS. New app version. Same issue. Getting really fed up of having to fix it. Especially now Monzo want a video when I set the app back up. :pensive:


Just to add. At this stage, with the amount of times I’ve had it happen, I believe I’ve identified the cause. It happens whenever the app is running in the background and you restart you phone for whatever reason. (It dies, you update it, or you turn it off, or you restart it as part of troubleshooting something else). I can reproduce the issue 100% of the time by force rebooting my phone whilst the app is running in the background (not swiped away).

It’s linked in some way to the other bug I’ve reported where the app opens but won’t load after your phone dies whilst the app is running in the background. Part of the troubleshooting to fix that issue involves rebooting your phone which in turn causes this one, and it means having to reinstall and reset the app twice if the other bug occurs first.