Monzo crashing on launch [Raised internally - investigating]

Okay so I’ve managed to solve the problem by creating an iCloud backup, starting from a fresh iPhone installing the monzo app and logining in, then resetting again and restoring my phone from the backup then reinstalling monzo. It must be something to do with my data being corrupted and still stored on my phone even after deleting the app. I reported all my crashes in TestFlight if you guys want to investigate further. Finally! :face_holding_back_tears:

1 Like

That’s a very over complicated process to get it working! Glad it is finally working for you again though!

Let’s just hope Monzo have a patch for this bug soon so it doesn’t break again! :crossed_fingers:


Arghhh I’ve just encountered this dreaded bug :sob::sob:.

My iPhone randomly restarted (not initiated by me) and now Monzo is crashing on launch :slightly_frowning_face:.

I’ll try deleting and reinstalling just now :pray:

1 Like

Got it working again :sweat_smile:

Don’t know if all these steps were necessary, but I reset the Monzo session in settings, deleted the app, switched phone off and back on, reinstalled app from the App Store, and it’s working again :slightly_smiling_face::pray:

1 Like

Annoyingly, deleting and reinstalling has made me lose the dark mode options in settings :slightly_frowning_face: so not quite back to normal.

Edit: now it’s appeared again lol…

1 Like

Dark mode settings has its own issue. Not sure if it’s a bug or intended given it was the same to activate it during beta (but it does feel like a bug). To get dark mode settings you need to quit the app and relaunch it after you first set it up.

1 Like

Ah! 4.40 crashed! Had to reinstall but the build isn’t available, gone through a few TestFlight builds, the latest one worked, but it broke Trends! It doesn’t update update, and trying to save different accounts/pots selections just stays loading forever. Trying to troubleshoot that broke the build, and now it won’t work.

When I try others I’m getting this weird flash of a broken version of the new logo before it shows the old one, then it crashes.

Have Monzo made any progress with this bug yet?

1 Like

I have the same issue in Trends where trying to save different accounts/pots selections just spins round and round forever when you click done.

1 Like

Thanks for confirming that’s not just me!

Made a thread for it here:

1 Like


Since iOS16 has graced us with it presence I’ve had to on average of 3-4 times a week delete the app, reboot the phone and download it again. The app constantly crashes out and l have never had this issue with any of the other versions of iOS.

It’s becoming quite a pain. Tell tail signs that I’m going to have to do it.

  1. The notification badge doesn’t disappear
  2. When I have to approve a payment
  3. If someone sends a payment request.

I have put up with it since it came out and I’ve gotten so fed up I did a clean install of my phone yesterday again. Last time prior to that was 5 weeks ago.

Is this something that other people are experiencing. Someone at my work showed me logs of where the iOS can see this happening.

Don’t know what more I can do. :woman_shrugging:t2:

There’s a few threads about it, Monzo are aware and investigating.


I totally agree with you. It’s such a pain that am considering using a more reliable bank.

This has been going on for a very long while now and still not fixed.

I was happy to download the updated app this week thinking it’s now fixed, but to my disappointment it’s still happening.

Monzo has not updated us on the cause of this issue.

1 Like

They have been aware for over a year now and not fixed

It’s not been that long! Only a few months, not that that makes it any more okay! I was one of the first victims to report the issue online, and was the first to do so here. I did some digging not too long ago to try to figure which version in particular it was that broke the app. It seems to coincide closely with when the summer cards were added to the app going from reports which started to crop up a week or two before my app crashed for the first time.

@AlanDoe it might be helpful to clean up and merge a bunch of the duplicate threads on this issue to save repeating all the really helpful troubleshooting and temporary fix methods folks have already found and shared.


This is the third time in 2 weeks I’ve had to remove and reinstall the app because it refuses to open. You provide ONE method of accessing your bank - the mobile app. No website. No tablet app. The mobile app. That’s it. And it doesn’t work. You’re a joke Monzo. 5 months is more than long enough to fix this issue, imagine how many people that don’t come to the forums are having this issue.

Sort. It. Out.

1 Like

I’ve not experienced this issue personally for quite a while now

Sporadic issues for a tiny amount of customers is going to be one of the hardest things to track down. Monzo are lucky that @N26throwaway is knowledgeable and managed to identify a big part of the cause and detail it, not just “It crashes”

But Monzo will want to fix it and will be spending time to do that, but with bugs it’s not as simple as “Sort it out”, they have to identify and work out how first.


Been having the same issue, frustratingly seems to happen only when I need to use the app urgently to check or approve something (though I doubt it’s worth including Sod’s Law in my bug report).

What information do I need to submit to the help@ email address that could help diagnose this?

Couple of times I’ve been trying to use TFL and since I can’t tap in because of insufficient funds and I can’t transfer money from a pot because the app is broken… gotta skip the bus! :grimacing:

1 Like

Anything you think causes it. @N26throwaway has managed to replicate it if his device restarts with Monzo running.

I wouldn’t bother with emailing though. Put your findings in this thread.

1 Like

I’d definitely do both. An email is probably properly logged etc, so I’d do that (as well as report on here).