Labs Feedback: 3DS 🔓


#382

I have the same issue on Android. I don’t want to be sent SMS every time and I rather have the option to approve within the app. Do you know from which version of the app on Android this feature was introduced?


#383

2.11.1

It’s currently in the beta channel on Google Play. I’m not sure when Monzo move it to production.

Liam


(Is Santa here yet?) #384

Turn it off in labs until android support in app confirmation


#385

Ok I’m the same version as you mentioned but I only get SMS. I guess I will turn it off for now until gets into production.


#386

Have you tried turning it off and on again?


(David Duncan-Fraser) #387

Yes I’m on Android, using Monzo v2.10.1


(Is Santa here yet?) #388

Once android has the in app authorisation like iOS it’ll work fine :+1:


(David I) #389

Just had my first 3DS payment and thought I should provide some quick feedback.

Notification was really quick so good there
On iOS I expected to be able to ForceTouch the notification and click Approve instantly. This is the behaviour of other authenticator apps I use (Example: Microsoft Authenticator)
I had to click notification and enter Monzo, complete touch authentication, click on transaction, complete touch authenticaiton again. This is lots of clicks and authentications for something which should be simpler (in my view).

Love the function would love it to be quicker and simpler UX to complete the authorisation.

David


#390

Is it supposed to work with the joint account card too yet? I got the embedded prompt on the retailer and the popup on my phone. Clicking the popup just brings my feed up within the app. Only options in the embedded prompt on the website are to cancel or say you’ve already approved it. No option to SMS. Had to completely cancel and disable in labs to get it to go through. On the very latest Android beta build and the website was Ocado. Just me jumping the gun a bit using the joint card? Looks very neat though.


((╯°□°)╯︵ ┻━┻) #391

I asked this question and got the following reply:


(MikeF) #392

Answer below applies to this I think.


(Dave) #393

I had a similar experience this evening. Required me to use Touch ID more than once, and then returned an error but on the web page it said approved. I then saw an error on the device that briefly said something about the error being because the payment had already been authorised (or words to that effect). Sorry I can’t be more specific but the error messages didn’t seem to hang around very long.

Good to see it as a feature though, and it will be very slick when the bugs are ironed out :slight_smile:


(Rhys Fowler) #394

Really like this so far but I’ve noticed there are some apps where once I switch into the Monzo app to approve, the payment fails.

Would it be possible to develop a notification that can be pulled down to reveal an Approve button (similar to what @FirstRulez mentioned)? Similar to this?


Launching 3D Secure!
(Kieran) #395

(Andy Little) #396

I just got the 3DS screen during a transaction. There was no option to enter a code and I didn’t get a text, so I checked in the app.

There was a feed item to allow me to accept or reject but I did not receive any notification to tell me it was there. Once I accepted it there, the transaction went through fine.

OnePlus 3
Android 8.0.0


(Peter Roberts) #397

I think OnePlus battery optimisation has been known to mess with Monzo push notifications. You could try disabling this for your Monzo app and see if that helps


(Andy Little) #398

All my other Monzo notifications work, but I’ll try disabling it and report back next time I get a 3DS screen.

Thanks.


(Lancelot Payne) #399

So I went to try and top up my oyster on the TFL website and I’ve got 3DS enabled in labs odd thing is it worked the other day but now it’s giving me a constant error saying invalid token has anyone else come across this with other websites as well as TFL.


(Rika Raybould) #400

If you turn Touch/Face ID for Authentication off and back on from Settings under your card in the Account tab, this should fix that issue.

A better fix should be coming but not sure on the timeframe right now.


(Lancelot Payne) #401

Thanks for that @Rika much appreciated I temporarily turned it off just to make the payment but will try it again soon and hopefully it will go through.