Card can't be used on Google Pay

I have recently moved over to Monzo and have set up my bank card with Google Pay. I keep encountering the same error, “This card can’t be used here”, and the payment fails.
All my other bank cards work with Google Pay.

From what I can gather my device is fully supported (Samsung G10+), on a non-rooted device. My Google play store device is certified. Monzo reports my card was verified with Google Pay correctly so I’m a bit of a loss here. Does Google Pay no longer support Monzo? Attached a few images of checks others have suggested in the past but essentially trying to track down who I should be contacting to get this resolved.

Thank you.

1 Like

Couple of thoughts here :eyes:

Are you seeing any declines show up in your monzo app or does the trail stop with Google pay’s error message?

It’s weird that it says “this card can’t be used with Google Pay here” - if it was due to root or a mental safetynet failure, the app tends to say “Google Pay can’t be used because the device has been rooted or modified in some way” (or something similar) and it wouldn’t allow you to add cards or use any cards to pay :see_no_evil:

I’d try either reinstalling the Google Pay app or just removing and re-adding your monzo card to GPay and ensuring you follow all the steps there :blush:

If you’re still having no luck, definitely send us a message through the in-app chat and we’ll do what we can to figure out what’s happening :hot_coral_heart:


Are you trying to use it in Google PLAY, as your text switches between Google Pay and Google Play references?

Could that make a difference? I don’t know the answer unfortunately. Does seem a strange one.

Was looking for any settings within the app (like Starling have) that may control how the card can be used, but cannot seem to find that element of control within Monzo.

So sorry about the Google Pay / Play mix up :face_with_hand_over_mouth: I have to blame my phone’s auto correct for that blunder. I was solely meant to refer to Google Pay but thank’s for highlighting, should know better to check before posting.

I just tried to use google pay with my Monzo card to make a google play purchase and it worked ok for me.

Quick update: Removed and Added Card with no luck.
Uninstalled and reinstalled Google Pay, no luck.
I then did some digging on internet. I also had my PayPal linked to my Google Pay and it was suggested this could cause issues. Either way I removed these details, just visited my local shop and instant success using my Monzo card on with Google Pay. :tada:
Perhaps a fault with Google Pay all along or a temporary fault but either way thanks for the suggestions. :smile:

1 Like

How many different places have you tried it? Just wondering if it was always at the same shop, or different ones.

Also, what does the screen on the chip and pin machine say?

Edit: you replied while I was typing, glad it’s sorted now!!

1 Like