Can't disable 'Show joint account first'

I used to have ‘Show joint account first’ enabled in Labs but decided to disable it.

However, even though it is showing as disabled in Labs, the joint account is still showing first.

I’ve tried force stopping the app, and reinstalling it, but the issue remains.

I’m using the Android app (version


This :bug: has been around since November 2020.

I reported it in-app at the time, but got a not-very-convincing ‘I’ve forwarded it to the development team’ response.

It doesn’t matter what the Labs toggle is set to, the JA is always first. Even on different devices with a fresh install of the :monzo: app, proving this is a server-side issue. Not many people use JA’s in anger so it’s likely to be a tiny issue in the grand scheme of things, but enough to annoy JA users.

To confuse matters further, another user (on iOS) reported they couldn’t get the JA to be first, regardless of the Labs setting - which is exactly the opposite to our experience of this issue.

1 Like