App doesn't work with data roaming switched off


(Roger Beschizza) #1

Arrived last night at hotel to find that my iPhone will not connect to Monzo as their WiFi is not secure, but my Starling app will. Is there a setting somewhere I need to alter? R-


#2

Hey, Roger.

Was there an error message at all?

I didn’t think the app would care about the internet connection to be honest, as long as there was one.


(Roger Beschizza) #3

Just that. Cannot connect connection not secure” roughly anyway. R-


(Roger Beschizza) #4

iPad seems to connect to any website. Just iPhone that is miss behaving.

Is there an iPad version of the app?

R-


(Roger Beschizza) #5

I didn’t think the app would care about the internet connection to be honest, as long as there was one.

That’s what I’d have thought. Bit of a nuisance as it also means can’t check cctv either.

R-


#6

Does this mean that your iPhone won’t connect for any app, or is it just Monzo (and, err, CCTV) that isn’t working?


(Roger Beschizza) #7

My apologies @Peter_G, I am typing in brilliant sunshine with a mild hangover, yes CCTV is how I should have expressed things.The iPhone seems ok with forums and the BBC (:white_check_mark:). R-


#8

No apologies necessary. I was just thinking that if there are problems with other apps as well as with Monzo then the problem is probably elsewhere.

Strange that Starling is working, though. In my experience they’ve always seemed a little more locked down.


(Change Works) #9

You can download the iPhone version to an iPad.


(Roger Beschizza) #10

All fixed in iPhone. Data roaming was turned off!! No idea how. Will try the phone app on iPad later on. Time for a beer. R-


(Roger Beschizza) #11

Hmmm… iPhone app not presented when searching on iPad. Any ideas for search phrase? R-


#12

I think there’s an option you need to tick / untick somewhere to let you see iPhone apps when on an iPad…

(Sorry to be vague #teamandroid here)


(Roger Beschizza) #13

Thanks @Peter_G, looks like I can link through iTunes. R-


#14

When you search on the App Store, there is a “Filters” dropdown to the left of the search bar. Selecting “iPhone Only” from the “Supports” menu will let you see iPhone-only apps.


(Roger Beschizza) #15

Just to report back that this has now been resolved. Didn’t use a search filter, just googled how to fix it and the app was presented. All done - time for a vino (I am in Spain after all). R-


(Allie) #16

This is odd to do since no network connection should be trusted. Why is Monzo enforcing this?